.NET Framework 4 Required

The VirtualShield Windows application is fully compatible with the following Operating Systems:
Windows 7, Windows 8, Windows 8.1, Windows 10

Windows 8, 8.1, and 10 all come included with Microsoft .NET Framework 4 right out-of-the-box. However, some installations of Windows 7 only come included with version 3.5.

If you receive the error message below you may need to install Microsoft .NET Framework 4.0 on your computer:

dotNet.jpg

There are two different versions of .NET 4.0 available on Microsoft's website, a standalone installer and a web-based installer. If you have a slow internet connection or your PC runs on battery, we recommend the web-based installer. Otherwise download the standalone installer.

You can download them both from the links provided below. Once .NET Framework 4.0 has been installed you can proceed to install VirtualShield.

Download the standalone installer:
https://www.microsoft.com/en-us/download/details.aspx?id=17718

Download the web-based installer:
https://www.microsoft.com/en-us/download/details.aspx?id=17851


If you're using Windows 7 SP1 (Service Pack 1) or later, we also recommend installing Microsoft .NET Framework 4.5.1. This is the latest version of .NET Framework 4 available.

This update is normally provided automatically by your Operating System, but in some cases you may need to download it manually. If you receive any other error messages during the installation, please try installing .NET Framework 4.5.1 on your computer.

Once .NET Framework 4.5.1 has been installed you can proceed to install VirtualShield.

Download the standalone installer:
https://www.microsoft.com/en-us/download/details.aspx?id=40779

Download the web-based installer:
https://www.microsoft.com/en-us/download/details.aspx?id=40773

Still need help? Contact Us Contact Us